Issue under investigation - Teams calling

Incident Report for Teams Connector

Resolved

The incident is resolved
Posted Apr 15, 2025 - 19:23 EDT

Update

As of 17:00 EDT inbound calling has stabilized except for a small subset of customers traversing the edge proxy pr1.connecttoteams.com (52.255.184.52). We have identified the cause of the issue and are working on a permanent solution. We expect full resolution within the next several hours. Updates will be provided as more information becomes available.
Posted Apr 15, 2025 - 17:10 EDT

Monitoring

Currently the calling service is stabilized, we still keep the provisioning portal disabled for the moment
Posted Apr 15, 2025 - 13:33 EDT

Update

Temporarily we disabled the provisioning portal in order to stabilize the service
Posted Apr 15, 2025 - 13:14 EDT

Investigating

The service is still having issues, currently we are further investigating
Posted Apr 15, 2025 - 12:23 EDT

Monitoring

The service is recovered, we continue to monitor the situation
Posted Apr 15, 2025 - 11:28 EDT

Identified

Currently the service is recovering, we are monitoring the situation and provide additional updates when available
Posted Apr 15, 2025 - 11:20 EDT

Investigating

We are aware of an issue that is affecting calling for a subset of customers. This issue appears to affect inbound calls. We are actively pursuing solutions and apologize for any interruption of service. Updates will be made as more information becomes available. (The issue is not affecting customers on dedicated infrastructure)
Posted Apr 15, 2025 - 10:06 EDT
This incident affected: PBX Connector, Call App, and Provisioning Portal.