We believe that the error causing this issue has been corrected. The most recent updatre from Microsoft is as follows: Current Status:
We identified a recent change that was strongly correlated with the onset of impact. We have completed the rollback of this change and telemetry across services are continuing to show signs of recovery. Customer should be observing recovery at this time.
We are closely monitoring service health and downstream recovery and will provide additional updates as we validate restoration.
Posted Jul 23, 2026 - 15:47 EDT
Update
We are continuing to investigate this issue.
Posted Jul 23, 2026 - 12:38 EDT
Investigating
We are aware of a issues with Azure Services connectivity that is affecting various ConnecttoTeams services. Login to the ConnecttoTeams portals using MS Oauth is currently not functioning. We have also received reports of 1-way and missing audio for customers homed to the US West region. We are monitoring the situation closely and will provide updates as more information becomes available. For further details, refer to the Microsoft Status page at https://azure.status.microsoft/en-us/status
Posted Jul 23, 2026 - 12:29 EDT
This incident affected: PBX Connector, SIP Trunk Connector, Provisioning Portal, and Microsoft Teams SIP Gateway.