Latest Teams clients ignore dialplan policy, impacting outbound extension dialing and resulting in an unwanted '+1' prefix

Incident Report for Teams Connector

Monitoring

We have discovered that recent updates to the Teams clients on Mac and Windows have corrected the dialplan issue.
The known "good" versions are

Windows11 26043.2016.4478.27
MacOS 26072.603.4515.6584

The availability of these versions may vary by region, and may depend on your specific release channel.

Microsoft has escalated our case and seems to be taking it seriously.
Posted Mar 31, 2026 - 22:54 EDT

Investigating

We have become aware of an issue with the latest versions of the Microsoft Teams clients. It appears as though the dialplan policy that should control outbound dialstring manipulation is not being obeyed, and the default Microsoft treatment is applied.

This may have different impacts depending on the specific dialplan rule customizations in a particular tenant, but the general effect is that any dialed number may have a '+CC' prefixed to the number before being sent onward. For example, dialing '1234' would typically be sent as '1234' using the default dialplan rule we install, but now we are seeing the number sent as '+11234' (which fails to reach the intended target and likely results in a rejected call).

The affected versions seem to include:

- MacOS desktop Version 26059.604.4471.2584

- Windows desktop 26058.713.4529.5861

There may be other versions on Mobile that have this issue as well.

Browser versions of Teams do not seem to have this problem.

We have opened a ticket with Microsoft. We will update this information as we receive updates.
Posted Mar 28, 2026 - 18:13 EDT
This incident affects: PBX Connector.