Issues when accessing portal

Incident Report for Teams Connector

Resolved

This incident has been resolved.
Posted May 29, 2026 - 09:31 EDT

Monitoring

A fix has been implemented, currently we are monitoring the situation
Posted May 29, 2026 - 08:12 EDT

Update

The Azure incident is still ongoing, we are still actively working on the service restoration
Posted May 29, 2026 - 07:18 EDT

Investigating

We are experiencing errors with the Azure storage service that are leading to some users experiencing issue when using the portal. We are actively pursuing solutions and apologize for any interruption of service. Updates will be made as more information becomes available. Calling and messaging is not affected.
Posted May 29, 2026 - 01:45 EDT
This incident affected: Provisioning Portal and API.